The LucidWorks Search UI fails with "A full JDK is required"

Symptoms

When trying to access the LucidWorks UI an error message similar to the following is presented:

PWC6345: There is an error in invoking javac. A full JDK (not just JRE) is required

 

Solution

If a full JDK is already installed, you can try the following solution to address this issue:

 

  1. Edit the master.conf file located under [LW_HOME]/conf
  2. Locate the lweui.jvm.params parameter
  3. Append the following line (with a space in front) to the end of the parameter value
    -Dorg.apache.jasper.compiler.disablejsr199=true
  4. Restart the LucidWorks Search services
  5. You should now be able to access the LucidWorks Search UI
    http://[hostname]:8989

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk